Raspberry-pi et chip USB-Serie FTDI

Si vos signaux X10 ne passent plus. Si votre liaison 1-wire est brouillée, je vous propose cette section pour exposer vos investigations, et pour partager des solutions avec les autres membres du site.

Raspberry-pi et chip USB-Serie FTDI

Messagede domos » 31 Déc 2012, 17:46

Bonjour,

J'ai fait le constat d'un problème de 'freeze' connu sur le Raspberry-pi avec les interfaces série-USB à base de chip FTDI FT232 comme celui utilisé dans le RFXCOM-USB.

J'ai mis à jour à la dernière version du kernel sous Raspian mais,
malgré tous les sujets traitant du problème, je n'ai trouvé que la solution de modification du paramètre "dwc_otg.speed" dans le fichier /boot/cmdline.txt.
dwc_otg.speed -> 1 will limit USB speed to full speed 12Mbps (USB 1.1)

En sachant que cela réduit aussi le débit du port ethernet car relié au bus USB.

Auriez vous trouver d'autre solutions au problème ?

merci
Domos

-------------------------------------------
Linux, Domogik
https://github.com/vdomos
http://vesta.homelinux.free.fr/
domos
Dieu de domotique
 
Messages: 263
Inscription: 14 Nov 2006, 13:24

Re: Raspberry-pi et chip USB-Serie FTDI

Messagede zemoled » 09 Jan 2013, 06:25

Je confirme,
J'ai un Raspberry avec 2 USB/RS232 + 1adaptateur 1wire. Il plantait sans arrêt

J'ai modifié le cmdline.txt avec le paramètre dwc_otg.spped=1 et ça semble tenir.... (pour le moment).
zemoled
Membre un peu timide !
 
Messages: 1
Inscription: 09 Jan 2013, 06:21


Retourner vers Parasites, Perturbations électriques !

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités

Copyright © 2011 - Touteladomotique.com - Tous droits réservés
Les blogs partenaires : Abavala, Domo-Blog, Domotique34, Maison et Domotique