[Téléinfo] Arduino + raspberry + minicom

mini2440, arduino, xbee, JeeLabs, Pic, picaxe ... Ici on parle de tous les montages Ă  base de microcontroleurs

[Téléinfo] Arduino + raspberry + minicom

Messagede domishao » 20 Nov 2013, 18:17

bonjour,

j'ai réalisé un montage de récupération de trame de téléinfo avec 2 optocoupleur 4n35. l'arduino est branché sur le raspberry via le port USB.
j'ai voulu rajouter une sonde de température et de là il m'est plus possible de récupérer des trames correcte sur le raspberry voici ce que minicom m'affiche

Code: Tout sélectionner
SOU 209

HCH 008035 0!
               HCP 01#85 277

P@E HP.

AI 08 ^
I
01 D
P
   CB
       OT@EAT 0 00 5
                        ADCO 040928014756 M

OPTARIF @C. <
ISUCC30 9

HHC 0 83%20  !

HP0128!5438 8

PECjIAA 001D


Sur le pc les trames sont nikel, j'ai bien entendu essayer de revenir en arriére de virer la sonde de température et de remettre le programme comme avant j'ai même reinstaller le systéme sur le raspberry mais rien n'y fait. j'ai essayé en alimentant la carte arduino indépendement de l'usb du raspberry.
dans minicom je suis bien en 1200 bauds 7E1 j'ai essayé différente vitesse mais celà n'as rien changé. y a t'-il d'autre réglage dans minicom qui pourrais causer ce probléme ?

en faisant un cat /dev/ttyACM0 en SSH la trame donne ça

Code: Tout sélectionner
0409"800h65& M
OPARHFHC,.<
IROSC 3  9                                                                     HCHP01385547  6
ITC HP. NSP  08 _
        MAX  41 @6x                                                            O0409"800h65& M
OPARHFHC,.<
IROSC 3  9                                                                     HCHP01385547  6
ITC HP. NSP  08 _
        MAX  41 PuTTYPuTTYPuTTYPuTTY I


le PuTTY qui s'incruste dans ma trame me fait demandé si j'ai pas un conflit avec Putty ? car effectivement j'utilise Putty pour me connecter au raspberry

avez vous une idée d'ou le probléme peut venir ?
domishao
Membre un peu timide !
 
Messages: 2
Inscription: 20 Nov 2013, 18:05

Re: [Téléinfo] Arduino + raspberry + minicom

Messagede domishao » 21 Nov 2013, 15:39

Probleme résolu
domishao
Membre un peu timide !
 
Messages: 2
Inscription: 20 Nov 2013, 18:05


Retourner vers Microcontroleurs

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités

Copyright © 2011 - Touteladomotique.com - Tous droits rĂ©servĂ©s
Les blogs partenaires : Abavala, Domo-Blog, Domotique34, Maison et Domotique