Drivers OPENWEBNET

Pour parler de tous les Problèmes/Bugs, Questions, Informations ... en rapport avec les drivers existants : Plcbus, X10, 1-Wire, Rfxcom, Zibase...

Modérateur: HoMIDoM

Re: Drivers OPENWEBNET

Messagede jphomi » 20 Juil 2017, 08:51

Bonjour,

Je ne connais absolument pas cette techno et je n'ai pas de matériel pour tester. Donc on va y aller à taton

J'ai modifié le driver pour avoir plus de log et essayer de trouver ou cela coince. Tu trouveras la version modifiée ici : https://github.com/Homidom/HoMIDoM/blob ... Net_IP.dll
J'ai rajouté un paramètre debug que tu renseignes à true pour avoir un complément de log. Quand ce sera ok, tu pourras le basculer à false.

Merci pour ton retour
@+
JP
Installation : Homidom sur serveur MSI DC111 sous Win10,Homiwpf sous Win8.1, Imperihome,
Jeedom pour test, phidgets SBC ( temp, pression, E/S )
Protocole ZWave (gestion chauffage fil pilote, eclairage, RGBW, eau chaude, suivi conso )
IPX800 (irrigation, Ă©clairage, temp)
Station météo NetAtmo ( temp, hum, pluvio, anémomètre )
Wattlet ( commande relai )
jphomi
P'tit Guru de domotique
 
Messages: 59
Inscription: 09 FĂ©v 2015, 10:56
Localisation: Aveyron (12)

Re: Drivers OPENWEBNET

Messagede naif » 24 Juil 2017, 13:45

Bonjour Ă  tous,
Tout d'abord très heureux de voir que les "bavardages" ont repris après ces quelques mois de silence.
Concernant OPENWEBNET, j'aimerais savoir si il est possible de le faire dialoguer avec des boitiers CPL équipés d'une prise USB (j'ai ce matériel). En effet, confronté à l'impossiblité de trouver une passerelle Legrand 88213, je me suis orienté vers ce type de solution (pour l'instant sans succès). Mon idée avec ce matériel dialoguer avec Homidom et mes inters CPL Legrand.
Partant du principe qu'il y a plus d'idées dans plusieurs têtes que dans une, peut être qu'une solution sera trouvée et je suis convaincu qu'elle sera bien accueillie par beaucoup
Bonnes vacances
Cordialement
naif
Dieu de domotique
 
Messages: 285
Inscription: 10 Oct 2014, 12:25
Localisation: Aisne

Re: Drivers OPENWEBNET

Messagede naif » 12 AoĂ» 2017, 15:52

Bonjour,
J'ai connecté un boitier CPL Netgear au serveur Homidom, le driver Openwebnet est démarré, lorsque j'encoie un teste "ON" j'ai dans le log le message suivant:
2/08/2017 16:50:02 - ERREUR - DRIVER - OpenWebNet IP Write - Non e' stata effettuata la connessione
12/08/2017 16:49:40 - ERREUR - DRIVER - OpenWebNet IP Write - Non e' stata effettuata la connessione
12/08/2017 16:49:22 - ERREUR - DRIVER - OpenWebNet IP Write - Une demande de connexion a été effectuée sur un socket déjà connecté
Avez vous une idée?
Cordialement
naif
Dieu de domotique
 
Messages: 285
Inscription: 10 Oct 2014, 12:25
Localisation: Aisne

Re: Drivers OPENWEBNET

Messagede 35vinc » 30 AoĂ» 2017, 14:07

Bonjour,

je suis de retour de congé et je vais donc pourvoir refaire des tests.
j'ai copier et coller le fichier téléchargé dans le dossier Drivers : https://github.com/Homidom/HoMIDoM/blob ... Net_IP.dll
j'ai changé le nom de l'ancien fichier et lancé homidom, il se passe deux choses :

1- lors du lancement du server j'ai le message suivant :
29/08/2017 18:28:56 ERREUR SERVEUR Drivers_Load Erreur lors du chargement du driver: Driver_OpenWebNet_IP.dll
Err: System.IO.FileLoadException: Impossible de charger le fichier ou l'assembly 'file:///C:\...\HoMIDoM\Drivers\Driver_OpenWebNet_IP.dll' ou une de ses dépendances.
L'opération n'est pas prise en charge. (Exception de HRESULT : 0x80131515)
Nom de fichier : 'file:///C:\...\HoMIDoM\Drivers\Driver_OpenWebNet_IP.dll'
---> System.NotSupportedException: Tentative de chargement d'un assembly à partir d'un emplacement réseau qui aurait entraîné l'utilisation de l'assembly en mode
Bac à sable (sandbox) dans les versions antérieures du .NET Framework.
Cette version du .NET Framework n'activant pas la stratégie CAS par défaut, ce chargement peut être dangereux.
Si ce chargement n'est pas destiné à utiliser l'assembly en mode Bac à sable (sandbox), activez le commutateur loadFromRemoteSources.
Pour plus d'informations, consultez http://go.microsoft.com/fwlink/?LinkId=155569.
Ă  System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity,
RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
Ă  System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity,
RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
Ă  System.Reflection.RuntimeAssembly.InternalLoadFrom(String assemblyFile, Evidence securityEvidence, Byte[] hashValue,
AssemblyHashAlgorithm hashAlgorithm, Boolean forIntrospection, Boolean suppressSecurityChecks, StackCrawlMark& stackMark)
Ă  System.Reflection.Assembly.LoadFrom(String assemblyFile)
Ă  HoMIDom.HoMIDom.Server.Drivers_Load()

2 - lors du lancement de l'interface homidom :
le driver OpenWebNet_IP n'apparait plus dans la liste des drivers !!!

soit il y a un problème avec le nouveau fichier ou j'ai fais une fausse manip, ou autre ... ??

merci pour ton retour jpHomi
35vinc
Membre un peu timide !
 
Messages: 9
Inscription: 21 Juin 2017, 09:12

Re: Drivers OPENWEBNET

Messagede NĂ©o32 » 31 AoĂ» 2017, 05:49

Bonjour 35vinc,

Normalement, il suffit de cliquer avec le bouton droit sur le fichier et va dans propriétés, en bas tu coches débloquer, ensuite appliquer et ca devrait être bon

Bonne journée
HoMIDoM- Le système complet et gratuit de domotique pour la maison
Avatar de l’utilisateur
NĂ©o32
Dieu de domotique
 
Messages: 680
Inscription: 07 Jan 2013, 08:09
Localisation: Charleroi (Belgique)

Re: Drivers OPENWEBNET

Messagede naif » 31 AoĂ» 2017, 09:58

Bonjour NĂ©o32,
Aurais tu une idée pour ma connection avec un CPL Netgear (message un peu plus haut)
Dans le driver j'ai mis l'adresse IP su serveur Homidom ainsi que son port (7999)
Dans le composant (where) l'id de l'inter CPL du volet roulant.
Merci pour tes réponses
Cordialement
naif
Dieu de domotique
 
Messages: 285
Inscription: 10 Oct 2014, 12:25
Localisation: Aisne

Re: Drivers OPENWEBNET

Messagede 35vinc » 03 Sep 2017, 14:28

Bonjour,

le message est le suivant :
03/09/2017 15:25:45 ERREUR CLIENT Divers Le driver n'a pas pu être démarré, veuillez consulter le log pour en connaitre la raison
03/09/2017 15:26:27 ERREUR CLIENT Divers ERREUR Sub AffControlPageSuite: La valeur ne peut pas ĂŞtre null.
Nom du paramètre : Les enfants de 'System.Windows.Controls.UIElementCollection' ne peuvent pas avoir la valeur null. Objet dérivé d'UIElement attendu.
35vinc
Membre un peu timide !
 
Messages: 9
Inscription: 21 Juin 2017, 09:12

Re: Drivers OPENWEBNET

Messagede NĂ©o32 » 11 Sep 2017, 20:24

Bonjour,

@ naif

Tu devrais mettre l'adresse de ton matérielle et pas celle de homidom

@ 35vinc

J'essaye de contacter jp pour qu'il regarde a ton probléme
HoMIDoM- Le système complet et gratuit de domotique pour la maison
Avatar de l’utilisateur
NĂ©o32
Dieu de domotique
 
Messages: 680
Inscription: 07 Jan 2013, 08:09
Localisation: Charleroi (Belgique)

Re: Drivers OPENWEBNET

Messagede naif » 13 Sep 2017, 09:10

Bonjour NĂ©o32
Merci pour ta réponse mais j'avais essayer sans résultat:
j'avais une erreur au niveau des socket (je ne me souviens plus exactement).
Depuis j'ai revendu mes adaptateurs CPL car je pense que mon idée n'est pas bonne. Dommage car j'aurais aimé pouvoir faire fonctionner mes inters volets CPL/IR in one de Legrand (réf 67251) avec le driver Openwebnet et ainsi m'affranchir de l'USBUIRT qui n'accepte pas le Windows 64.
Cordialement et bonne journée
naif
Dieu de domotique
 
Messages: 285
Inscription: 10 Oct 2014, 12:25
Localisation: Aisne

Re: Drivers OPENWEBNET

Messagede jphomi » 16 Sep 2017, 10:13

Salut,

J'ai regardé un peu tes logs, j'ai recompilé la dll openwebnet dans le mème framework que le driver dans le doute. Elle se trouve ici : https://github.com/jphomi/JP-OpenWebNet ... WebNet.dll
Que le driver n'apparaisse pas dans la liste des driver c'est normal vu le message. Il ne peut se charger.
Mais j'ai peur d'être arrivé trop tard vu ton dernier post.

Si tu as encore le matériel, pourras tu tester ?

A+
JP
Installation : Homidom sur serveur MSI DC111 sous Win10,Homiwpf sous Win8.1, Imperihome,
Jeedom pour test, phidgets SBC ( temp, pression, E/S )
Protocole ZWave (gestion chauffage fil pilote, eclairage, RGBW, eau chaude, suivi conso )
IPX800 (irrigation, Ă©clairage, temp)
Station météo NetAtmo ( temp, hum, pluvio, anémomètre )
Wattlet ( commande relai )
jphomi
P'tit Guru de domotique
 
Messages: 59
Inscription: 09 FĂ©v 2015, 10:56
Localisation: Aveyron (12)

Re: Drivers OPENWEBNET

Messagede naif » 18 Sep 2017, 15:31

Bonjour jphomi,
Je ne sais si ton message s'adresser à moi mais j'ai récupéré 2 boitiers CPL
Olitec200.
J'ai installé ton driver
Malheureusement j'ai ce message dans le log lorsque je souhaite démarrer le driver:
18/09/2017 16:26:16 - ERREUR - CLIENT - Divers - Le driver n'a pas pu être démarré, veuillez consulter le log pour en connaitre la raison
18/09/2017 16:26:01 - ERREUR - SERVEUR - StartDriver - Exception : Impossible de charger le type 'OpenWebNet.WebServer' Ă  partir de l'assembly 'OpenWebNet, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.
Peut être as tu une idée.
L'adresse IP est apparemment celle des boitiers quant au port j'ai mis celui de Homidom (7999)
Un boitier est connecté à la livebox et l'autre au PC serveur sur lequel est installé Homidom.
Merci pour ton aide
Cordialement
naif
Dieu de domotique
 
Messages: 285
Inscription: 10 Oct 2014, 12:25
Localisation: Aisne

Re: Drivers OPENWEBNET

Messagede jphomi » 18 Sep 2017, 21:11

Bonjour naif,

Effectivement, je mélange un peu les conversation. Te concernant, je vais essayer de bien me recaler.
Si j'ai bien compris, tu avais avant 2 prises cpl Netgear et maintenant 2 prises Olitec 200. Ces prises sont branchées au réseau électrique dans 2 pièces différentes.
Un fois que tes prises sont pairées ( 1 diode doit te l'indiquer ), tu as branché, par une prise RJ45, une prise sur ta box et une autre sur ton serveur. L’intérêt du montage c'est d’éviter de tirer un câble réseau entre les deux pièces.

Concernant tes inters Legrand, j'ai bien peur que faute de trouver une plug usb 88213 tu ne pourras plus les piloter. J'ai essayé de regarder sur le net un petit peu mais je n'ai rien trouvé de probant.
Si j'ai bien compris, pour les commander, il te faut soit une radio commande ou une télécommande IR. Après le protocole CPL est propre à la marque. Chaque marque a sa trame de commande, le netgear ne comprend pas le olitec et ... J'ai trouvé cela http://www.homecinema-fr.com/forum/inst ... 30-45.html mais pas sur que cela t'aide beaucoup.

Donc pour utiliser Homidom comme commande, il faudrait déjà avoir un périphérique compatible Legrand faisant la liaison entre le réseau et tes inters.

Dis moi si j'ai bien compris.
A bientot
JP
Installation : Homidom sur serveur MSI DC111 sous Win10,Homiwpf sous Win8.1, Imperihome,
Jeedom pour test, phidgets SBC ( temp, pression, E/S )
Protocole ZWave (gestion chauffage fil pilote, eclairage, RGBW, eau chaude, suivi conso )
IPX800 (irrigation, Ă©clairage, temp)
Station météo NetAtmo ( temp, hum, pluvio, anémomètre )
Wattlet ( commande relai )
jphomi
P'tit Guru de domotique
 
Messages: 59
Inscription: 09 FĂ©v 2015, 10:56
Localisation: Aveyron (12)

Précédente

Retourner vers Drivers

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités

Copyright © 2011 - Touteladomotique.com - Tous droits rĂ©servĂ©s
Les blogs partenaires : Abavala, Domo-Blog, Domotique34, Maison et Domotique