Actualités | Audio/Vidéo | Evènements | DIY | Domotique | Informatique | Maison | Mobile | Sécurité

OpenWRT & PirateBox sur le TP-Link WR703N

Envoyer Imprimer PDF
Note des utilisateurs: / 5
MauvaisTrès bien 

Bonjour à vous moussaillons,

Aujourd'hui je vais flirter avec le côté obscur du kopimisme en vous parlant de la "PirateBox". Avant de commencer à vous faire installer cet outil, je vais vous expliquer ce qu'est une PirateBox et à quoi elle sert.

En avant!!

Préface

Dans mon introduction je vous ai parlé de kopimisme, pour ceux qui n'ont pas suivi le lien, je vais donc vous expliquer rapidement ce que c'est.

Il s'agit d'une religion reconnu en Suède qui sacralise le partage de l'information. Certains kopimistes ont pour Dieu Thot, qui n'est autre que le dieu du savoir et de l'écriture en ancienne Egypte.

Cette description, même si elle est un peu hors sujet, est une très bonne introduction au sujet qui nous intéresse aujourd'hui, c'est à dire la "PirateBox".

 

 

Qu'est-ce qu'une PirateBox?

C'est un système de partage ouvert (libre d'accès) ou on offre aux utilisateurs la possibilité de déposer, consulter ou télécharger divers documents.

L'idée principale est donc le partage de l'information autant que du contenu. Il est souvent utilisé pour partager ses œuvres (musiques, texte, vidéo, ...) ou pour se promouvoir dans certains cadres.

Les PirateBox prennent tout leur sens dans la mobilité, en effet si elle reste à la maison ou sur un réseau privée elle devient inerte et sans intérêt, car les personnes y ayant accès seront toujours les mêmes et l'information ne voyagera donc que très peu. Tandis que si on la transporte lors de nos différents déplacements ou pour les événements auxquels nous participons au quotidien (concerts, exposition, groupes de travail, ...) le public touché se diversifie et le plein potentiel de ce service est atteint : La libre circulation de l’information.

L'exemple que j'aime utiliser pour promouvoir ce type de service est le cadre du concert ou des festivals de rue. En effet on y croise souvent de nombreux artistes et la PirateBox peut donc être utilisé par eu afin de faire connaitre leurs œuvres (musical, poétiques, ...) à coût 0 et à un public qui n'aurait, sans cela, pas forcément été attiré par ce genre artistique...

 

Ethique

Ce partage pose également certains problèmes éthiques notamment par rapport à la nature même des "œuvres" téléchargées. En effet s’il est simple de poster ou de rédiger en direct un poème de sa création, il est tout aussi simple de partager une œuvre disposant d'un copyright ou possédant un caractère choquant (pédophilie, appel à la haine, ...). Il est donc important de surveiller régulièrement le contenu mis à disposition dès lors que nous sommes dans un environnement non contrôlé.

Afin de limiter ce type de problème les PirateBox créent souvent un réseau local et entièrement séparé de tout réseau (notamment Internet). Ainsi il faudra une forte promiscuité afin de pouvoir partager ou profiter du contenu partagé.

 

Autre petit point important. Certaines entreprises et/ou organisation n'accepterons peut-être pas d'avoir dans leurs périmètres un réseau ouvert, d'autant plus si celui-ci porte le doux nom de "PirateBox" et invite à partager des informations, qui dans le cadre professionnel peuvent-être très sensibles. Pensez donc que si l'endroit où vous vous trouvez est un tant soit peu organisé et sécurisé il peut être intelligent d'éteindre votre routeur, cela fera du bien à l'image des PirateBox (ou du moins ne lui fera pas de mal) et pourrait même vous éviter quelques soucis.

 

Le matériel

Comme expliqué précédemment la mobilité et le fait d'être sur un réseau particulier nous oriente vers l'utilisation d'un routeur. Heureusement il existe bon nombre de routeurs Wifi de petites tailles et consommant peu d'électricité et la PirateBox pourra dans de très nombreux cas être directement installée sur eux.

Il est également envisageable d’utiliser un PC Portable ou un micro PC du type « Raspberry-Pi » ou « OLinuxino », l’inconvénient dans ces deux cas est la consommation électrique et la puissance du wifi qui les composent.

L'autre besoin est le stockage, en effet il est important de prévoir cela lors de l'achat du matériel. Si vous partez sur un mini routeur il faut pouvoir y brancher au minimum une clé USB.

Le dernier prérequis est de pouvoir changer le firmware (sorte de système d'exploitation intégré à tout matériel). Les PirateBox sont la plupart du temps installée sur "OpenWRT" mais il est également possible de l'installer sur un Linux ou même sur Android.

De plus en plus de personnes possèdent un Smartphone, dans la plupart des cas (si ce n'est tous) ils sont doté d'une connexion Wifi et de stockage intégré ainsi que d'une batterie leur permettant une grande mobilité (et oui c'est quand même leur but premier). Il est donc alors très simple d'utiliser un Smartphone (par exemple sous Android mais d'autres OS doivent le permettre) comme PirateBox.

Pour ma part je vais utiliser un mini routeur TP-Link WR703N aimablement prêté par Domotics.

 

Le dernier besoin matériel est, lui, facultatif. C’est une batterie afin de profiter pleinement de la PirateBox dans toutes les situations. J'utilise pour ma part une batterie TechNet 7000Mah 1A et mon routeur fonctionne plus de 24h mais sans aucun transfert ni personne de connecté, cela laisse, toutefois, présager une très bonne autonomie en utilisation.

Avant de procéder à l’installation je vais vous présenter le routeur que j’utilise. Comme je l’ai dit c’est un TP-Link WR703N qui est trouvable sur internet pour un prix avoisinant les 30€ ou même moins si comme Domotics vous trouvez une version chinoise sur dealextreme.com.

A la base il permet de brancher une clé 3G et ainsi de partager cette connexion 3G vers plusieurs appareils facilement.

Si vous l’achetez pour cette fonctionnalité je ne saurai que trop vous conseiller de laisser de côté les versions chinoises car l’interface est très peu compréhensible si vous ne pratiquez pas la langue.

Ce routeur mesure moins de 6cm de côté pour un peu plus de 1 cm de haut. Pour vous faire une idée il est plus petit qu’un demi-paquet de cigarette et guère plus lourd (quand le paquet est vide ;-) ).

Il est alimenté par un port micro-USB ce qui est très pratique pour trouver plein d’accessoires intéressants (batterie pour téléphone portable, chargeur allume-cigare, …) ou trouver facilement un câble en déplacement. Pour rappel le micro-USB est la nouvelle norme pour les chargeurs de mobile et est donc de plus en plus utilisé.

 

Il possède également un port USB femelle qui permet d’y brancher entre autre une clé USB.

Pour finir de parler de lui disons que son prix très attractif permet de trouver de nombreuses améliorations sur Internet. Notamment, vous trouverez très facilement des tutoriaux pour mettre une antenne Wifi externe afin d’étendre sa portée, comment placer la clé USB à l’intérieur du boitier, comment permettre l’utilisation de disque USB alimenté par le port USB, et de très nombreuses modifications.

Toutes ces raisons font que le WR703N est une très bonne PirateBox.

Voyons maintenant comment le transformer afin d’avoir ce service de partage au fond de sa poche.

 

Installation


La préparation de mon routeur ainsi que l'installation de la PirateBox est très simple et rapide, il faut compter 1h au maximum avec une connexion internet convenable.

Pour récapituler les étapes nous allons :

- Flasher le routeur avec la dernière version d’OpenWRT.
- Installer le service PirateBox.
- Configurer le routeur ainsi que le service PirateBox.
- Profiter pleinement de notre nouveau jouet.

 

Préparation du routeur

Cette section ne vous concerne que si vous utilisez le même routeur que moi, encore une fois, j'utilise le TP-Link WR703N en version Chinoise. Vous verrez rapidement que cette dernière information est importante ;-).

Si par contre vous utilisez un autre routeur il vous faudra trouver comment installer OpenWRT sur celui-ci.
Fort heureusement OpenWRT est un grand classique et est largement utilisé, il est donc très facile de trouver des tutoriaux pour l'installer sur la plupart des matériels. Il faut faire attention avant d'acheter votre routeur qu'il soit bien supporté par OpenWRT (vérifiez jusqu'à la version qui a son importance).

 

Flash du Firmware

Avant tout, il nous faut télécharger la version d’OpenWRT correspondant à notre routeur. A l'heure où j'écris ces lignes la version suivante est la plus récente, sinon vous pouvez voir sur le site http://downloads.openwrt.org/snapshots/trunk/ar71xx/.

Je le télécharge donc via ce lien et l'enregistre sur mon PC http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin.

Note : Avant l’étape suivante pensez à sauvegarder ou imprimer ce tutorial car vous allez certainement perdre la connexion internet (sauf si vous êtes en Wifi).

Une fois le téléchargement terminé débranchez votre PC du réseau et le relie via un câble Ethernet (RJ45) au routeur. Une fois fait et le routeur alimenté par l'USB il démarre automatiquement, rendez-vous à l'adresse: http://192.168.1.1.

Vous vous retrouvez normalement devant une interface web. Si vous avez, comme moi une version chinoise, vous vous retrouvez face à la page suivante. Cliquez donc sur le dernier menu puis sur le troisième sous-menu.

Cela vous ouvre donc la page centrale où vous pouvez cliquer sur le bouton à droite de la fenêtre blanche. Ensuite choisissez sur votre PC le fichier précédemment téléchargé. Et pour finir cliquez sur le dernier bouton juste en dessous. Plusieurs barres de chargement vont apparaitre, laissez le navigateur et le routeur charger jusqu'à la fin.

Attention lors de cette étape le routeur est "flashé" et donc la connexion entre le PC et le routeur ne doit pas être interrompue, il vaut donc mieux ne pas utiliser de batterie pour le routeur comme pour le PC et ne pas trop bouger le câble réseau.

Dans mon cas cette étape a duré 2 minutes donc si cela dure moins longtemps pour vous je vous invite à attendre quelques secondes de plus car le travail n’est pas être pas encore terminé.

Une fois fini vous êtes redirigé vers une page avec une erreur 404 (« page not found » ou « impossible d’afficher la page »).

Si vous avez une autre version que ma chinoise, je vous invite à chercher le menu permettant de faire une mise à jour du firmware, et d'y charger le fichier précédemment téléchargé.

Après cette mise à jour du micro-logiciel le routeur devrait redémarrer. Sinon il vous suffit de le débrancher une dizaine de secondes puis de le rebrancher.

Maintenant que le routeur a redémarré vous pouvez vous y connecter via "telnet" afin de le configurer un petit peu. Pour ce faire j'utilise le logiciel MobaXterm mais vous pouvez utiliser putty ou même directement dans la "cmd" si vous avez une version de Windows antérieur à Vista. Si vous avez un Linux aucun logiciel n'est nécessaire, il vous suffit d'ouvrir le terminal et de rentrer la commande suivante:

telnet 192.168.1.1

Une fois connecté nous allons configurer le réseau, pour le faire il faut éditer le fichier /etc/config/network et mettre le contenu suivant:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'

#Adresse du routeur, à modifier celons votre réseau
option ipaddr '192.168.0.2'
option netmask '255.255.255.0'

#Adresse de la passerelle, à modifier celons votre réseau
option gateway '192.168.0.254'

#Adresse du DNS principal, à modifier celons votre réseau
list dns '192.168.0.254'

#Adresse du DNS secondaire, à modifier celons votre réseau
list dns '8.8.8.8'

Une fois ce fichier enregistré vous pouvez redémarrer le routeur en débranchant la prise USB du routeur (alimentation) au moins 10 secondes. Ensuite branchez le WR703 sur votre réseau et rebranchez votre PC au même réseau. Vous pouvez maintenant rebrancher l'alimentation du routeur.

Continuons la configuration en changeant le mot de passe ce qui va activer le SSH et désactiver le Telnet.

telnet 192.168.0.2
passwd
exit

On se connecte donc en SSH sur le routeur. Si vous êtes sous Windows vous pouvez encore utiliser MobaXTerm ou putty.

SSH root@192.168.0.2

On vérifie que l'accès à internet fonctionne afin de pouvoir installer les packages de la suite de l'article.

ping www.google.fr

 

Si cela fonctionne vous pouvez continuer sinon vérifiez le fichier précédemment édité.

Si le test de connexion fonctionne vous êtes face à un système OpenWRT fonctionnel. Il ne permet pas de faire du partage de fichier mais peut vous rendre tous les autres services fournis par OpenWRT (cf. site internet de OpenWRT).

 

Installation de PirateBox

Passons maintenant à l’installation de la PirateBox à proprement parlé. Il vous faut maintenant brancher une clé USB sur le routeur. Attention cette clé USB devra être reliée au routeur dès que le système fonctionne. Elle est nécessaire pour utiliser le routeur même si le service PirateBox ne vous intéresse pas.

Cette clé USB peut être utilisé pour autre chose mais ne doit pas être formaté ou le dossier PirateBox à sa racine ne doit pas être effacé sinon vous devrez réinstaller OpenWRT et la PirateBox.

Votre clé USB doit être suffisamment grosse pour contenir tous les partages de vos utilisateurs, cependant elle doit être formatée en FAT32 avec une seule partition.

 

Pour la suite vous devez donc avoir redémarré le routeur sous OpenWRT avec sa clé USB dédiée branchée sur son port.

Reconnectez-vous en SSH.

Vous pouvez vérifier qu'elle est correctement reconnu en utilisant la commande "dmesg". Si elle est bien reconnue vous verrez deux lignes apparaitre après avoir inseré la clé USB .

L'installation de PirateBox se déroule très simplement avec les commandes suivantes:

cd /tmp
wget http://piratebox.aod-rpg.de/piratebox_0.5.1_all.ipk
opkg update && opkg install piratebox*

 

Et voilà votre PirateBox est installée. Pour le vérifier, après avoir redémarré le routeur et l'avoir débranché de votre réseau RJ45, rejoignez son réseau Wifi et ouvrez votre navigateur internet. Vous devriez être redirigé vers l'adresse suivante: http://piratebox.lan et vous retrouvez face à l’image suivante.

 

Vous pouvez donc ajouter un fichier grâce au bouton entouré de vert.

Accéder aux fichiers partagés grâce au bouton entouré de bleu.

Et dans le rond rouge se trouve la zone de chat instantanée qui permet aux personnes connectées de discuter en temps réel entres elles.

Attaquons nous à la configuration de la PirateBox.

Il est possible de modifier le nom du réseau grâce au fichier /etc/config/wireless en modifiant la ligne:

option ssid 'Le nom de mon AP'.

 

Si vous souhaitez garder la configuration réseau de base de la PirateBox, en 192.168.1.1, votre PirateBox est prête à être utilisée. Si comme moi vous préférez pouvoir la brancher à votre réseau Ethernet de la maison et que vous êtes sur une autre plage réseau (192.168.0.0 pour free) il vous faut modifier les trois fichiers suivants :

/etc/defconfig/wndr3700/network et modifier la ligne :

option ipaddr   192.168.1.1

 

/etc/piratebox.common en ne touchant que les lignes suivantes :

pb_ip="192.168.1.1"
uci set "network.lan.ipaddr=192.168.1.1"

 

/etc/preinit pour finir:

pi_ip=192.168.1.1
fs_failsafe_ip=192.168.1.1

 

Et voilà tout devrait fonctionner.

Vous voyez que c’était très simple et qu’à ce prix il serait dommage de se priver.

Voyons maintenant comment retourner à un OpenWRT brut sans l’installation de PirateBox afin de profiter autrement de ce routeur ou de préparer une autre clé USB.

 

Procédure de réinstallation sur une nouvelle clé

Si vous utilisez une autre clé USB que celle préparée lors de la première installation vous remarquerez vite que cela ne fonctionne pas, votre périphérique ne pourra pas se connecter au réseau. Sur mon téléphone Android cela se traduit par l’impossibilité de récupérer une adresse IP.

Pour pouvoir utiliser une autre clé USB il suffit de copier le contenu de la première clé sur la nouvelle. Il n’y a pas besoin de copier tout son contenu, le dossier « PirateBox » et le fichier « piratebox_ws_img.tar.gz » sont amplement suffisant pour la PirateBox mais pas forcément suffisant si vous avez installé d’autres choses sur votre OpenWRT.

Une fois cela fait votre PirateBox fonctionne à merveille sur la nouvelle clé. Je vous invite donc à sauvegarder ce contenu car si vous perdiez la première clé USB ou si elle est amenée à tomber en panne il vous faudra tout réinstaller.

Puisque je suis bon et que j’ai un peu de temps je vais vous préparer le travail juste au cas où.

 

Réinstallation de votre PirateBox

Dans cette section nous verrons seulement comment réinstaller le service PirateBox sans toucher au reste (autres programmes, configuration réseau, …).

C’est très simple, il vous faut vous connecter via SSH à la PirateBox.

ssh root@192.168.0.2
 rm -rf /overlay/*

 

Suite à ça vous vous retrouvez à la même étape qu’après avoir effectué le flashage. Il ne vous reste plus qu’à reconnecter votre PC en direct, à vous connecter en telnet, … Et continuer le tutoriel.

 

Voilà pour aujourd’hui. Je vous laisse profiter de votre PirateBox et trouver où l’installer pour découvrir et partager d’innombrables informations.

Vous n'avez pas compris un point ? Vous vous posez une question ? Vous pouvez nous contacter via le bouton Assistance sur votre droite ou laissez nous un message au 09 75 18 51 41

Vous avez aimé cet article ? N’oubliez pas de le partager sur les réseaux sociaux pour soutenir TLD.

 

Cet article vous est proposé par ElkAin : Technophile Toulousain, il souhaite retransmettre ce que l'Internet lui a appris. Sa devise : Mieux vaut penser les changements que changer les pansements.

Mise à jour le Vendredi, 11 Janvier 2013 00:44  

Ajouter un Commentaire


Code de sécurité
Rafraîchir

Recherche

Les Flux RSS de TLD
Instagram

Produits Partenaires

GCE Electronics est partenaire de Touteladomotique.com RFXCOM.com est partenaire de Touteladomotique.com



Liens Utiles

Boutiques Partenaires

Liens Utiles

Un don pour TLD ?

Pourquoi faire un don ?

Publicité

Espaces publicitaires à louer
Contactez-nous

Connexion